1925684 – ABAP adjustments for the new Embedded Statistic Server

Symptom

This SAP Note refers to the following SAP HANA revisions:

  • SAP HANA Revision 74 (SPS 7) and higher
    Comprehensive adjustments are required in all ABAP-based monitoring and administration tools for SAP HANA if one of the following points applies:

    • You have manually activated the new embedded statistics server.
    • You use an SAP HANA multiple container system (in this case, the embedded statistics server is always active).
    • You use Revision 93 or above (in this case the embedded statistics server is active by default, cf. SAP Note 2121080).
  • All HANA revisions
    You want to extract the metrics for the new alerts 52 through 59 to SAP Solution Manager.

Reason and Prerequisites

  • SAP HANA Revision 74 (SPS 7) and higher:
A. To monitor and administrate an SAP HANA database, use one of the following tools:
– DBA Cockpit
– Solution Manager Alerting Infrastructure
– Solution Manager Performance Warehouse

B. This SAP HANA database has been upgraded to SAP HANA Revision 74 (SPS 7) or higher.

C. You have activated the new embedded statistics server in one of the following ways:

  • Manually
  • The embedded statistics server is always active in SAP HANA multiple container systems.
  • The embedded statistics server is active by default as of Revision 93.

All HANA revisions:

You use the Solution Manager Alerting Infrastructure and you want to extract the metrics for the new alerts 52 through 59.

Solution

The solution below is involves the two cases described above:
Import the following SAP_BASIS Support Packages:
7.02 SP15
7.30 SP11
7.31 SP11
7.40 SP06
The above releases and Support Packages contain all the necessary ABAP adjustments.

If you use the following SAP_BASIS Support Packages:
7.02 SP14 or SP13
7.30 SP10
7.31 SP09 or SP10
7.40 SP04 or SP05
you can implement the necessary ABAP adjustments by implementing the source code contained in this SAP Note.
Note that we cannot provide these adjustments for older SAP_BASIS Support Packages, due to the extensive program modifications involved.

Important: When you import the source code from this SAP Note, several new ABAP methods are created. This may cause problems (syntax errors) during future upgrades of the SAP_BASIS Support Package if you do not use the latest version of SNOTE. You may also have problems (syntax errors) uninstalling this SAP Note if you do not use the latest version of SNOTE. Therefore, immediately before the next SP upgrade or immediately before you uninstall this SAP Note (if applicable), implement the newest version of SNOTE and the newest version of SAP Note 1720495 if the SP prerequisites from this SAP Note match your planned upgrade. This will avoid the problems described above during your next upgrade.

Leave a Reply